Информатика, вопрос задал fdffrf , 7 лет назад

Составить программу, моделирующую работу супермаркета с кассами. Должна использоваться многопоточность. В целом задание творческое, поэтому не нужно писать, что каких-то данных не хватает. Чего не хватает - задаем своим решением. Язык программирования - си шарп.

Ответы на вопрос

Ответил artemcebunin89
0

Ответ:

C#

interface X

{

public void doThis(int user);

public void doLog(string message);

}

class OS:Thread, X

{

public OS( int user){

doThis(user);

}

public void doThis(int user){

doLog("Started:"+DateTime.Now.ToString());

doLog("Action:"+"doThis"+"with userID:"+user));

doLog("Finished:"+DateTime.Now.ToString());

}

public void doLog(string message);

Console.WriteLine(message);

}

public static void Main() {

Thread t = new Thread(new OS(1));

t.Start();

}

0

Новые вопросы