Составить программу. Массивы распечатать в виде матрицы! Номер 2! В матрице
Приложения:

Ответы на вопрос
Ответил Аноним
0
const
m = 5;
n = 5;
var
x: array[1..m, 1..n] of real;
i, k: integer;
s: real;
begin
writeln('исходный массив');
for i := 1 to m do
begin
for k := 1 to n do
begin
x[i, k] := (cos(k) + sin(i)) / (sqrt(k) + sqr(i));
write(x[i, k]:9:5)
end;
writeln
end;
writeln('Суммы элементов матрицы по четным колонкам');
k := 2;
while k <= n do
begin
s := 0;
for i := 1 to m do s := s + x[i, k];
k := k + 2;
write(s:11:5)
end;
writeln
end.
Результаты работы программы:
исходный массив
0.69089 0.17618 -0.05436 0.06261 0.34769
0.28992 0.09108 -0.01408 0.04261 0.19130
0.06814 -0.02641 -0.07910 -0.04659 0.03781
-0.01274 -0.06736 -0.09851 -0.07836 -0.02595
-0.01610 -0.05206 -0.07291 -0.05972 -0.02479
Суммы элементов матрицы по четным колонкам
0.12144 -0.07946
m = 5;
n = 5;
var
x: array[1..m, 1..n] of real;
i, k: integer;
s: real;
begin
writeln('исходный массив');
for i := 1 to m do
begin
for k := 1 to n do
begin
x[i, k] := (cos(k) + sin(i)) / (sqrt(k) + sqr(i));
write(x[i, k]:9:5)
end;
writeln
end;
writeln('Суммы элементов матрицы по четным колонкам');
k := 2;
while k <= n do
begin
s := 0;
for i := 1 to m do s := s + x[i, k];
k := k + 2;
write(s:11:5)
end;
writeln
end.
Результаты работы программы:
исходный массив
0.69089 0.17618 -0.05436 0.06261 0.34769
0.28992 0.09108 -0.01408 0.04261 0.19130
0.06814 -0.02641 -0.07910 -0.04659 0.03781
-0.01274 -0.06736 -0.09851 -0.07836 -0.02595
-0.01610 -0.05206 -0.07291 -0.05972 -0.02479
Суммы элементов матрицы по четным колонкам
0.12144 -0.07946
Новые вопросы