Составить программу которое забрашивает четырёхзначное число и находит сумму цифр четырёхзначного числа и определяет делиться на 5.
Ответы на вопрос
Ответил fedrfedr
3
Ответ:
program numsum;
uses
SysUtils;
var
n, i, sn: Integer;
s: string;
begin
Write ('Введите четырехзначное число: ');
ReadLn (n);
n := Abs (n);
if (n > 9999) or (n < 1000) then begin
WriteLn ('Введенное число не четырехзначное');
ReadLn;
Exit;
end;
s := IntToStr (n);
sn := 0;
for i := 1 to Length (s) do
sn := sn + StrToInt (s [i]);
WriteLn ('Сумма цифр числа = ', sn);
if sn mod 5 = 0 then
WriteLn ('Сумма цифр делится на 5')
else
WriteLn ('Сумма цифр не делится на 5');
ReadLn;
end.
Новые вопросы
Литература,
1 год назад
Геометрия,
2 года назад
Физика,
2 года назад
Алгебра,
7 лет назад
Английский язык,
7 лет назад