Информатика, вопрос задал Pikachu32 , 8 лет назад

составить программу,которая заменяет все нечетные числа на 46(массив из A целых чисел формируется случайным образом в интервале [16;28]
помогите пожалуйста

Ответы на вопрос

Ответил nkpk
0
const n=10;var a,i:integer; mas:array [1..n] of integer; begin randomize; for i:=1 to n do   mas[i]:=random(16,28);  writeln('исходный массив');  for i:=1 to n do  write(mas[i]:4);   for i:=1 to n do   if  mas[i] mod 2 <> 0 then  mas[i]:=46;  writeln();  writeln('После изменения ');  for i:=1 to n do   write(mas[i]:4);   end.
Ответил nkpk
0
const n=10;
var
a,i:integer;
mas:array [1..n] of integer;
begin
randomize;
for i:=1 to n do
mas[i]:=random(16,28);
writeln('исходный массив');
for i:=1 to n do
write(mas[i]:4);
for i:=1 to n do
if mas[i] mod 2 <> 0 then
mas[i]:=46;
writeln();
writeln('После изменения ');
for i:=1 to n do
write(mas[i]:4);
end.
Ответил nkpk
0
вот так лучше видно
Новые вопросы