Составить программу, которая выводит все натуральные числа до 100 и кратных 5.
Ответы на вопрос
Ответ:Pascal ABC.NET
var i:integer;
begin
for i:=1 to 100 do
if i mod 5=0 then write(i:4);
end.
===== PascalABC.NET =====
begin
var i := 5;
while i <= 100 do
begin
Print(i);
i += 5
end
end.
Объяснение:
Понятно, первое натуральное число, кратное 5 - это 5. Все прочие должны получаться прибавлением 5 к предыдущему, т.е. это числа 10, 15, 20, ... 95. Входит ли в эти числа 100, из условия непонятно. Обычно, чтобы не было двусмысленности, для указания включения 100 в диапазон значений используют термины "не более 100", "до 100 включительно", "не превышающие 100", а "до 100" понимают как "меньше 100", т.е. как указание, что 100 включать не нужно.
Программа написана для случая, когда 100 включается в диапазон Если число 100 включать не нужно, в операторе whiie i <= 100 do из условия <= удалите знак равенства =.
