Информатика, вопрос задал Goblin21 , 2 года назад

составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел.

Ответы на вопрос

Ответил kssuvik
0

Для начала каких чисел?

Они вводятся или нет?

Ох, ладно

Допустим, вводятся)

Python

Я ввожу число и все положительные числа, которые входят в него будут проходить через программу...

n = int(input())

g = 0

l = 0

for i in range(n+1):

   g += 1

   l += i

g -= 1

print( l // g )

Пример

Ввод: 5

Вывод: 3

Как получилось:

1+2+3+4+5=15

кол-во цифр = 5

15 / 5 =3

Как-то так


Goblin21: числа не вводятся, мне нужно через составной оператор begin...end
kssuvik: Так это вообще другой язык
kssuvik: В задаче следует уточнять на каком языке ты хочешь получить ответ
Goblin21: в паскале, блиин поможешь??
kssuvik: Нет.Я его уже не помню , т.к. этот язык популярен только для школьной программы
kssuvik: Сори
Новые вопросы