Информатика, вопрос задал dariaosipova13 , 7 лет назад

Составить программу, которая вычисляет площадь треугольника заданного координатами своих вершин. Используя формулу Герона. вычисления расстояния между двумя точками оформить в виде процедуры или функции

Ответы на вопрос

Ответил sanyamar
0

Попроси решение у одноклассников и просто поменяй название переменных. Я сам так всегда делаю

====================

Решение

====================

Program n1;

Procedure qwe(x1,x2,y1,y2:integer);

var a,b,c,p:real;

begin

a:= x2-x1;

b:= y2-y1;

c:= sqrt((a*a)+(b*b));

p:=(a+b+c)/2;

writeln(sqrt(p*(p-a)*(p-b)*(p-c)));

end;

var i,o,p,l:integer;

begin

read(i,o,p,l);

//Вводить в формате x1,x2,y1,y2

qwe(i,o,p,l);

end.


Новые вопросы