Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000.
Ответы на вопрос
Ответил CzarAlex
0
var i, c : integer;
begin
for i := 1 to 1000 do
if (i mod (3*4*5) = 0)
then c := c + 1;
writeln(c);
end.
begin
for i := 1 to 1000 do
if (i mod (3*4*5) = 0)
then c := c + 1;
writeln(c);
end.
Ответил Аноним
0
мейби:
program n_1;
var i,c: integer;
begin
c:=1;
for i:=1 to 1000 do
if (i mod 3=0) and (i mod 4=0) and (i mod 5=0) then
c:= c + 1;
end;
writeln (c);
end.
program n_1;
var i,c: integer;
begin
c:=1;
for i:=1 to 1000 do
if (i mod 3=0) and (i mod 4=0) and (i mod 5=0) then
c:= c + 1;
end;
writeln (c);
end.
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!
begin
Range(1,1000).Where(t->t mod 60=0).Count.Println
end.
Результат
16
Внимание! Если программа не работает, обновите версию!
begin
Range(1,1000).Where(t->t mod 60=0).Count.Println
end.
Результат
16
Ответил Аноним
0
Если число одновременно кратно нескольким числам, оно также кратно их НОК. В данном случае НОК = 3*4*5 = 60.
Новые вопросы