Информатика, вопрос задал Nesquikoptistart , 8 лет назад

Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. (язык pascal)
пожалуйста...

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),1,200); a.Println;
  Writeln('Ср.арифметическое кратных 3: ',
      a.Where(t->t mod 3=0).DefaultIfEmpty.Average)
end.

Пример
n= 15
185 103 5 33 116 167 189 36 79 110 188 12 26 11 10
Ср.арифметическое кратных 3: 67.5
Ответил Аноним
0
Но тогда надо так и писать.
Ответил Аноним
0
Описка: 3,6,9, ... 195, 198.
Ответил Nesquikoptistart
0
мне вообще как нибудь по проще нужно....
Ответил Nesquikoptistart
0
мы еще рандом не проходили)))
Ответил Аноним
0
И мы должны догадаться, как Вам надо и что Вы проходили?
Ответил elenaklon
0
Если всё-таки нужно среднее арифметическое всех чисел, кратных 3, в диапазоне от 1 до 200

var i,s,k:integer;
begin
for i:=1 to 200 do
if i mod 3 = 0 then begin
s:=s+i;
k:=k+1
end;
writeln ('Среднее арифметическое чисел, кратных 3, в диапазоне от 1 до 200 равно: ',s/k)
end.
Новые вопросы