Информатика, вопрос задал Мирося2012 , 10 лет назад

составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 (каждое число с новой строки), и если среди них есть неотрицательное число, то выводит это число или выводит сумму всех отрицательных введенных чисел в остальных случаях.

Ответы на вопрос

Ответил MrsSima
0

Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite chisla');
Readln(a,b,c);
If(a<0)and(b<0)and(c<0) then writeln('Summa = ',a+b+c)
else
if (a>0) then writeln('polozhitelnoe chislo ',a) else
if (b>0) then writeln('polozhitelnoe chislo ',b) else
if (c>0) then writeln('polozhitelnoe chislo ',c);
readln
end.

Новые вопросы