составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата.
процедура P1 вводит с клавиатуры длину стороны квадрата;
функция F1 вычисляет площадь квадрата;
Процедура P2 выводит на экран результат.
процедура P1 и функции F1 - встроенный в программу
процедура P2 - записывается как отдельный модуль подключаемый к основной программе.
в паскале
Ответы на вопрос
программа на Turbo pascal 7.1:
содержание progs.pas:
{$N+}{-директива для подключения 8087 препоцессора}
uses output1; {здесь подключаем модуль output1}
var p:double;
function F1(p:double):double;
begin
F1:=Sqr(p);
end;
procedure P1(var p:double);
begin
readln(p);
p:=F1(p);
end;
begin
write('Введите длину стороны квадрата = ');
P1(p);
P2(p);
end.
содержание output1.tpu:
{$N+}{-директива для подключения 8087 препоцессора}
unit output1;{здесь объявляем модуль output1}
interface
procedure P2(p:double);
implementation
procedure P2;
begin
writeln('Площадь квадрата = ',p:0:5);
end;
end.