Составить программу, которая в зависимости от порядкового номера месяца (1,2,...,12) выводит на экран количество дней в этом месяце. Год может быть високосным ( информация об этом вводится с клавиатуры )
В С++ пж 30 баллов
Ответы на вопрос
Ответ:
Объяснение:
#include <iostream>
#include <cstdlib>
using namespace std;
int main() {
setlocale(0, "");
int q = 28, w = 30, e = 31,a;
cout << "Введите номер месяца:";
cin >> a;
if (a < 1){ cout << "Ошибка ввода месяца" << endl; }
if (a < 2){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 3){ cout << "Количество дней в месяце: " << q << endl; }
else if (a < 4){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 5){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 6){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 7){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 8){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 9){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 10){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 11){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 12){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 13){ cout << "Количество дней в месяце: " << e << endl; }
else if (a > 12){ cout << "Ошибка ввода месяца" << endl; }
system("pause");
return 0;