Информатика, вопрос задал deniska01k , 8 лет назад

составить программу которая в массиве из 10 элементов находят произведение минимума и максимума значимых элементов

Ответы на вопрос

Ответил Hyrule
0
type
  mas = array [1..10] of integer;
var
  x: mas;
  min, max: integer;
  i: integer;
begin
  for i := 1 to 10 do
    readln (x[i]);
  min := x[1];
  max := x[1];
  for i := 2 to 10 do begin
    if x[i] < min then
       min := x[i];
    if x[i] > max then
      max : =x[i]
  end;
  writeln (max * min);
end.
Ответил Hyrule
0
Ошибочка: max := x[1];
Новые вопросы