Информатика, вопрос задал Sm0k4 , 10 лет назад

Составить программу,которая упорядочивает 2 числа по убыванию и находит максимальное из них.

Ответы на вопрос

Ответил pifagor0
0
var a,b:integer;
begin
writeln(a);
readln(a);
writeln(b);
readln(b);
if a>b then writeln(a, ', ', b) else writeln(b, ', ',a);
if a>b then writeln(a, ' - максимум') else writeln(b, ' - максимум');
end.

Ответил Аноним
0
По убыванию! А у тебя наоборот. И упорядочивает! А не выводит в нужном порядке!
Ответил pifagor0
0
По убыванию это от большего к меньшему, проверяйте программу. Также моя программа упорядочивает числа от большего к меньшему и находит максимальное из них.
Ответил Аноним
0
Да, прости.. Косяк.. На твоя программа просто выводит в нужном порядке! А не упорядочивает!!
Ответил Sky09
0
uses crt;
var x,y,max: real;
begin
     read(x,y);
     writeln;
     if x>y then begin
        write(x,' ',y);
        max:=x;
     end
     else begin
          max:=y;
          write(y,' ',x)
     end;
     writeln;
     writeln('Максимум: ',max);
end.
Ответил Аноним
0
См. Коммент выше! И максимум можно искать намного проще.. Есть стандартная процедурка в модуле math (я про фрии), а со своими недоделками абц далеко не уйдешь..
Новые вопросы