Информатика, вопрос задал pravilosagarchika , 9 лет назад

Составить программу , которая уменьшает первое число в два раза а второе увеличивает на 1 если первое больше 2

Ответы на вопрос

Ответил Ammalu
0
Var
A,d:integer
Begin
Read(a);
Read(d)
Write(a*2);
Begin
If (a>d) then
Write(d+1)
End;
End.
Ответил noskovee
0
не верно.
Ответил Ammalu
0
Поставь ';' где надо
Ответил noskovee
0
сама логика не верна.
Ответил noskovee
0
1) файл паскаля приложен.
2) код на c#
        static void Main(string[] args)        {            int a, b;            a = Convert.ToInt32(Console.ReadLine());            b = Convert.ToInt32(Console.ReadLine());            if (a > 2)            {                Console.WriteLine(a / 2);                Console.WriteLine(b - 1);            }        }
3) Код на vb
dim a as integer = 0
dim b as integer = 0
a = cint(console.readline())
b = cint(console.readline())
if a > 2 then
console.writeline( a / 2)
console.writeline(b - 1)
end if
Приложения:
Новые вопросы