Информатика, вопрос задал 14794567 , 10 лет назад

составить программу которая строит изображение предмета в плоском зеркале (расстояние от предмета до зеркала вводиться с клавиатуры).

Ответы на вопрос

Ответил sinbad7
0

Картинка должна быть в папке с программой и быть в формате BMP

uses
graphabc;

var
n: string;
b: Picture;
s:integer;

begin
writeln('введите расстояние до зеркала');
readln(s);
write('Введите имя файла рисунка: ');
readln(n);
window.Clear;
b := Picture.Create(n);
b.Load(n);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(50+2*s,50);
end.

Новые вопросы