Информатика, вопрос задал dariaosipova13 , 7 лет назад

Составить программу, которая считывает элементы двумерного массива и меняет отрицательные элементы на -1, положительные на 1. Полученную матрицу выводит на экран. (паскаль)

Ответы на вопрос

Ответил nubpolymaster
0

var a: array of array of integer;

i, j, n, m: integer;

begin

read(n, m);

setlength(a, n);

for i := 0 to n - 1 do

begin

setlength(a[i], m);

for j := 0 to m - 1 do

begin

read(a[i][j]);

if (a[i][j] > 0) then

a[i][j] := 1

else if (a[i][j] < 0) then

a[i][j] := -1;

end;

end;

for i := 0 to n - 1 do

begin

for j := 0 to m - 1 do

begin

write(a[i][j]);

write(' ');

end;

writeln();

end;

end.

Ответил Hdj1
0

program znan;

var

x:array [1..1000, 1..1000] of longint;

m,n,i,j:LongInt;

begin

ReadLn(n,m);

for i:=1 to n do

for j:=1 to m do

begin

Read(x[i,j]);

if x[I,j]>=0 then

x[I,j]:=1 else

x[I,j]:=-1;

end;

for i:=1 to n do

for j:=1 to m do

Write(x[i,j], ' ');

end.


Новые вопросы