Информатика, вопрос задал volt11 , 9 лет назад

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы). В паскаль.

Ответы на вопрос

Ответил ihorsyrota
0
program p1;
var st1,st:string;
i,c:integer;
begin
writeln('Введите текст');
readln(st);
for i:=1 to length(st) do
begin
st1:=copy(st,i,1);
if st1='а' then c:=c+1;
end;
write('К-во раз: ',c);
end.
Ответил ihorsyrota
0
Либо если нужно явно указать текст:
Ответил ihorsyrota
0
program p1;
var st1,st:string;
i,c:integer;
begin
st:='Секретные материалы';
for i:=1 to length(st) do begin
st1:=copy(st,i,1);
if st1='а' then c:=c+1;
end;
write('К-во раз: ',c);

end.
Ответил volt11
0
Большое спасибо! Очень помогли!)
Новые вопросы