Информатика, вопрос задал dimaperfeckt , 2 года назад

Составить программу, которая преобразует введённое с клавиатуры дробное число в денежный формат например 27,5 - 25 руб 50 коп
паскаль!!!!!!!!

Ответы на вопрос

Ответил MGXFrost
1

Ответ:

var

a : double;

begin

readln(a);

writeln(trunc(a), ' руб ', (frac(a) * 100):2:0, ' коп');

end.

Объяснение:

Получаем дробное число и затем выводим его в нужном формате.

trunc(a) получает целую часть от числа

frac(a) получает дробную часть от числа, затем умножаем на 100 для преобразования дробной части в целую(для вывода на экран) (например 0.22 преобразуется в 22.0) и с помощью :2:0 выводим в фомате 2 цифры до запятой и 0 после.

Новые вопросы