Составить программу, которая позволяет ввести рост N учащихся, найти средний рост учащихся и количество учеников с ростом выше (ниже)160 см?
Ответы на вопрос
Ответил anurgaziyev
0
int n;
cin >> n;
int counter = 0;
int sum = 0;
int curr;
for (int i = 0; i < n; i++) {
cin>>cur;
if (curr >= 160) {
sum += curr;
counter++;
}
}
cout<<"количество"<<counter<<endl;
cout<<"средный"<<(sum / (double) counter) << endl;
cin >> n;
int counter = 0;
int sum = 0;
int curr;
for (int i = 0; i < n; i++) {
cin>>cur;
if (curr >= 160) {
sum += curr;
counter++;
}
}
cout<<"количество"<<counter<<endl;
cout<<"средный"<<(sum / (double) counter) << endl;
Ответил 90misha90
0
в условии указанно строго выше или строго ниже
Ответил anurgaziyev
0
тогда if ( curr != 160 )
Ответил 90misha90
0
не надо так, вот так тогда: if (curr > 160)
Ответил 90misha90
0
......................
Приложения:



Новые вопросы