Информатика, вопрос задал Komanolga , 9 лет назад

Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые обладают тем свойством, что число, образованное первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число, образованное последними двумя цифрами.

Ответы на вопрос

Ответил geula
0
var
  a, b, c, d, e, n: integer;

begin
  n := 0;
  for a := 1 to 9 do
    for b := 0 to 9 do
      for c := 1 to 9 do
        for d := 0 to 9 do
          for e := 0 to 9 do
            if (10 * a + b) * c = (10 * d + e) then n := n + 1;
  Writeln(n)
end.

Тестовое решение:
196
Ответил VALar
0
НЕ учтены случаи, когда три последние цифры нули, т.е. такие числа как 11000, а для них тоже выполняется требование 11*0=00, т.е. 11*0=0. Таким образом набегает еще 90 чисел. Мне кажется, что я не противоречу ни заданию, ни математике.
Новые вопросы