Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара.
Ответы на вопрос
Ответил Аноним
0
const
Pi=3.1416;
var
n:integer;
r:real;
begin
Write('Укажите вариант расчета и радиус: ');
Read(n,r);
case n of
1:Writeln('Длина окружности равна ',2*Pi*r);
2:Writeln('Пдощадь круга равна ',Pi*r*r);
3:Writeln('Объем шара равен ',4/3*Pi*r*r*r)
else Writeln('Вариант должет быть равен 1,2 или 3')
end
end.
Пример
Укажите вариант расчета и радиус: 3 11.7
Объем шара равен 6708.8365344
Pi=3.1416;
var
n:integer;
r:real;
begin
Write('Укажите вариант расчета и радиус: ');
Read(n,r);
case n of
1:Writeln('Длина окружности равна ',2*Pi*r);
2:Writeln('Пдощадь круга равна ',Pi*r*r);
3:Writeln('Объем шара равен ',4/3*Pi*r*r*r)
else Writeln('Вариант должет быть равен 1,2 или 3')
end
end.
Пример
Укажите вариант расчета и радиус: 3 11.7
Объем шара равен 6708.8365344
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Химия,
9 лет назад
Алгебра,
9 лет назад