Составить программу которая организует вввод в массив записей следующих данных об учащихся: имя, фамилия, возраст, школа, класс из файла INPUT.DAT (не больше 10 человек)
Ответы на вопрос
Ответил Аноним
2
type
sc=record
name:string;
fam:string;
age:byte;
school:integer;
clas:string
end;
var
i,n:integer;
a:array[1..10] of sc;
f:Text;
begin
Writeln('Читаем данные из файла input.txt');
Assign(f,'input.txt'); Reset(f);
n:=0;
while (not Eof(f)) and (n<10) do begin
Inc(n);
Readln(f,a[n].fam); Readln(f,a[n].name);
Readln(f,a[n].age); Readln(f,a[n].school);
Readln(f,a[n].clas)
end;
Close(f);
Writeln('Принято записей: ',n);
Writeln('Контрольный вывод');
for i:=1 to n do
begin
Writeln('Школьник ',i,':');
Write(a[i].name,' ',a[i].fam,', ');
Write(a[i].age,' лет, школа №',a[i].school);
Writeln(', класс ',a[i].clas)
end
end.
Тестовое решение:
Читаем данные из файла input.txt
Принято записей: 3
Контрольный вывод
Школьник 1:
Иванов Иван, 14 лет, школа №126, класс 7б
Школьник 2:
Петров Петр, 13 лет, школа №18, класс 6а
Школьник 3:
Семенова Валентина, 15 лет, школа №52, класс 8г
Файл input.txt для тестового решения находится во вложении.
sc=record
name:string;
fam:string;
age:byte;
school:integer;
clas:string
end;
var
i,n:integer;
a:array[1..10] of sc;
f:Text;
begin
Writeln('Читаем данные из файла input.txt');
Assign(f,'input.txt'); Reset(f);
n:=0;
while (not Eof(f)) and (n<10) do begin
Inc(n);
Readln(f,a[n].fam); Readln(f,a[n].name);
Readln(f,a[n].age); Readln(f,a[n].school);
Readln(f,a[n].clas)
end;
Close(f);
Writeln('Принято записей: ',n);
Writeln('Контрольный вывод');
for i:=1 to n do
begin
Writeln('Школьник ',i,':');
Write(a[i].name,' ',a[i].fam,', ');
Write(a[i].age,' лет, школа №',a[i].school);
Writeln(', класс ',a[i].clas)
end
end.
Тестовое решение:
Читаем данные из файла input.txt
Принято записей: 3
Контрольный вывод
Школьник 1:
Иванов Иван, 14 лет, школа №126, класс 7б
Школьник 2:
Петров Петр, 13 лет, школа №18, класс 6а
Школьник 3:
Семенова Валентина, 15 лет, школа №52, класс 8г
Файл input.txt для тестового решения находится во вложении.
Приложения:
archery:
так же как большенство документации на английском. Непонятна переменная - есть словарь, может поможет
Новые вопросы
Русский язык,
1 год назад
Литература,
2 года назад
Математика,
2 года назад
География,
7 лет назад
Биология,
7 лет назад