Информатика, вопрос задал irishka1609 , 7 лет назад

Составить программу которая определяет по номеру месяца соответствующее время года

Ответы на вопрос

Ответил farodis
0

1 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

case a of

1:writeln('Зима');

2:writeln('Зима');

3:writeln('Весна');

4:writeln('Весна');

5:writeln('Весна');

6:writeln('Лето');

7:writeln('Лето');

8:writeln('Лето');

9:writeln('Осень');

10:writeln('Осень');

11:writeln('Осень');

12:writeln('Зима');

end;

end.

2 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

if (a=12) or (a=1) or (a=2) then writeln('зима');

if (a=3) or (a=4) or (a=5) then writeln('весна');

if (a=6) or (a=7) or (a=8) then writeln('лето');

if (a=9) or (a=10) or (a=11) then writeln('осень');

end.

Новые вопросы