Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=Abs(ReadInteger('Введите целое трехзначное число'));
if n.Between(100,999) then
if n.ToString.Select(c->c).Distinct.Count<3 then
Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
else Writeln('Число должно быть трехзначным')
end.
Внимание! Если программа не работает, обновите версию!
begin
var n:=Abs(ReadInteger('Введите целое трехзначное число'));
if n.Between(100,999) then
if n.ToString.Select(c->c).Distinct.Count<3 then
Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
else Writeln('Число должно быть трехзначным')
end.
Ответил petyaGavrikov
0
var a,a1,a2,a3:integer;
begin
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1=a2)or(a1=a3)or(a2=a3)
then writeln('Одинаковые цифры есть')
else writeln('Одинаковых цифр нет');
end.
Пример:
121
Одинаковые цифры есть
begin
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1=a2)or(a1=a3)or(a2=a3)
then writeln('Одинаковые цифры есть')
else writeln('Одинаковых цифр нет');
end.
Пример:
121
Одинаковые цифры есть
Новые вопросы
Українська мова,
2 года назад
Українська мова,
2 года назад
Математика,
8 лет назад
Химия,
8 лет назад
Математика,
9 лет назад