Составить программу которая находит корни неполного квадратного уравнения
Ответы на вопрос
Ответил kristi555000
0
program koren;
var a,b,c,diskr,x1,x2:real;
begin
readln (a,b,c);
if a=0 then exit;
diskr:=b*b-4*a*c;
if diskr<0 then exit;
x1:=(-b-sqrt(diskr))/(2*a));
x1:=(-b+sqrt(diskr))/(2*a));
writeln (x1,x2);
end.
var a,b,c,diskr,x1,x2:real;
begin
readln (a,b,c);
if a=0 then exit;
diskr:=b*b-4*a*c;
if diskr<0 then exit;
x1:=(-b-sqrt(diskr))/(2*a));
x1:=(-b+sqrt(diskr))/(2*a));
writeln (x1,x2);
end.
Новые вопросы
Английский язык,
2 года назад
Немецкий язык,
2 года назад
Математика,
9 лет назад
Литература,
9 лет назад