Составить программу, которая меняет элементы массива на противоположные по знаку, массив заполняется с клавиатуры.
Решить задачу на паскале.
Ответы на вопрос
Ответил Аноним
0
PascalABC
var a:array of real;
i,n:integer;
begin
write('Задайте размер массива = ');readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
writeln('Исходный массив: ',a);
for i:=0 to n-1 do a[i]:= -a[i];
writeln('Полученный массив: ',a);
end.
var a:array of real;
i,n:integer;
begin
write('Задайте размер массива = ');readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
writeln('Исходный массив: ',a);
for i:=0 to n-1 do a[i]:= -a[i];
writeln('Полученный массив: ',a);
end.
Ответил vladmor
0
В PascalABC.Net проверил, работает.
Ответил Аноним
0
Возможно ты вместе с надписью "PascalABC" программу пытался запустить?
Ответил LOmasetr3
0
нет брат
Ответил Аноним
0
значит ты пытался её запустить в другой среде, отличной от ABC ( Turbo, Free и т.д.)
Ответил LOmasetr3
0
нет в ABC он пишет что нужны [ ] а что в них писать?
Новые вопросы