Составить программу, которая генерирует 10 случайных чисел в диапазоне от -20 до 30,выводит эти числа на экран и вычисляет сумму отрицательных
Ответы на вопрос
Ответил saypl
0
var a:array[1..10] of integer;
i,s:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(51)-20; write(a[i],' '); end;
writeln;
s:=0;
for i:=1 to 10 do
if a[i]<0 then s:= s+a[i];
writeln('Сумма отрицательных чисел равна ', s);
end.
i,s:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(51)-20; write(a[i],' '); end;
writeln;
s:=0;
for i:=1 to 10 do
if a[i]<0 then s:= s+a[i];
writeln('Сумма отрицательных чисел равна ', s);
end.
Новые вопросы