Информатика, вопрос задал Holyyyyyy , 9 лет назад

Составить программу,которая формирует одномерный массив и выводит на экран все элементы,кратные 7.

Ответы на вопрос

Ответил mnv1962
0
const
n=10;
var
a:array[1..n]of integer;
i,k:integer;
    begin
        for i:=1 to n do
               begin
                   a[i]:=random(100);
                    write(a[i]:4);
                end;
writeln; 
           for i:=1 to n do
                if a[i] mod 7=0 then
                 begin
                      write(a[i]:4);
                      k:=k+1;
                 end;
if k=0 then
    writeln('нет кратных 7')
end.

          

Новые вопросы