Информатика, вопрос задал kripton4545 , 9 лет назад

Составить программу, которая бы запрашивала Хнач и Хкон и определяла произведение всех положительных чисел от Хнач до Хкон (решить задачу, используя цикл с предусловием – While .. Do). Пож помогите

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Pascal WDE

Var
 xk,xn:real;
 i,r,xik,xin:integer;
 b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
 begin
  r:=r*i;
  b:=true;
 end;
inc(i);
end;
if b=true then write(r) else write('0');
end.

Пример ввода:
-2.8
3.8
Пример вывода:
6
Новые вопросы