Информатика, вопрос задал timanna , 9 лет назад

Составить программу, которая будет вводить N чисел и искать максимальное число среди этих чисел.
1<=a[i], N<=100

Ответы на вопрос

Ответил Анилай
0
const
n=100;
var
a:array[1..n] of integer;
max,i:integer;
begin
randomize;
for i:=1 to n do
begin
writeln(a[i]='');
readln(a[i]);
end;
max:=a[1];
for i:=2 to n do
If a[i]>max then begin
max:=a[i];
end;
writeln;
writeln('Max=',max);
readln;
End.
Ответил Аноним
0
Хотя, она скорее не ошибка, а описка.
Ответил Анилай
0
Что же здесь я неправильно сделала?
Ответил Аноним
0
Я же Вам направил решение на исправление, там в комментарии написано
Ответил Аноним
0
max:=a[i]; перед for i:=2 to n do. Должно быть max:=a[1]
Ответил Анилай
0
Спасибо Вам, сама не заметила, как перепутала
Новые вопросы