Информатика, вопрос задал timanna , 2 года назад

Составить программу, которая будет вводить десять чисел и подсчитывать количество пятерок среди этих чисел.

Пример ввода:

1
6
10
5
7
42
5
9
5
11
Пример вывода:

3
(Паскаль)


alexooooon: 1 Программа рандомно цифры выводит?
2 пятерки: а если будет цифры 15, то это считается?
3 если рандомно то до какого числа

Ответы на вопрос

Ответил Pelageya
1
program zadacha;
var a,i,k: integer;
begin
k:=0;
writeln('Введите 10 чисел ');
for i:=1 to 10 do
begin
readln(a);
if a=5 then k:=k+1;
end;
writeln('Количество пятерок равно ',k);
end.

alexooooon: >program zadacha;
alexooooon: можно убрать
alexooooon: >k:=k+1;

inc(k) будет грамотнее
Аноним: Inc() и Dec() есть не во всех версиях Паскаля
Аноним: Но в подавляющем большинстве версий - есть
Pelageya: Это верно, только меня, например, в школе не учили inc. Несмотря на то, что уже давно учусь не в школе, делая задания здесь, всегда ограничиваюсь именно школьными знаниями, так как боюсь, что автор задания не поймет, или его преподаватель увидит, что ученик откуда-то списал.
Аноним: Потому что Н.Вирт изначально в описании Паскаля не вводил этих процедур, посчитав, что достаточно иметь Succ() и Pred().
Новые вопросы