Составить программу, которая будет считывать введённое четырехзначное число. Каждую цифру этого числа необходимо вывести в новой строке
Ответы на вопрос
Ответил iolandavalerypad353
0
// PascalABC.NET
begin
var num: integer;
while true do
begin
num := ReadlnInteger('введите 4-х значное число, num =');
if (num > 999) and (num <= 9999)
then break;
end;
var str := num.ToString;
foreach var x in str do
Println(x)
end.
begin
var num: integer;
while true do
begin
num := ReadlnInteger('введите 4-х значное число, num =');
if (num > 999) and (num <= 9999)
then break;
end;
var str := num.ToString;
foreach var x in str do
Println(x)
end.
Ответил SloImagineDragons
0
cпасибо, но мне на паскале нужно было ,сам виноват я что не уточнил
Ответил SloImagineDragons
0
))
Ответил SloImagineDragons
0
+ много ошибок в твоей программе
Ответил iolandavalerypad353
0
там легко перевести в freepascal, всего несколько правок, к сожалению не могу, ответ заблокирован, жаль
Ответил igorShap
0
var a,f:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
Новые вопросы
Математика,
8 лет назад
Алгебра,
8 лет назад