Информатика, вопрос задал kakaunttina06 , 7 лет назад

Составить программу. Коммерсант, имея стартовый капитал k рублей, занялся торговлей, которая ежемесячно увеличивает капитал на p%. Через сколько лет он накопит сумму s, достаточную для покупки собственного магазина? ПРОСТО ХЭЛП

Ответы на вопрос

Ответил ivashnko
0

var

 n,s,p:integer;

 l,k:real;

 

begin

 readln(k);

 readln(p);

 readln(s);

 n:=0;

 repeat

  l:=k*p/100;

  k:=l+k;

  n:=n+1;

 until k > s;

 write(n div 12,'Лет',n mod 12,'Месяцов');

 readln;

end.

взял отсюда: https://studassistent.ru/turbo-pascal/kommersant-imeya-startovyy-kapital-turbo-pascal

Новые вопросы