Информатика, вопрос задал gkjj , 2 года назад

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

Ответы на вопрос

Ответил therealcf2014
1
var a, b, c: integer;
begin
write('Введите углы a, b, c >> ');
readln(a, b, c);
if a+b+c = 180 then
if (a>0) and (b>0) and (c>0) then
begin
if (a=b) and (b=c) then writeln('Равносторонний ');
if ((a=b) and (a<>c)) or ((b=c) and (b<>a)) or ((a=c) and (c<>b)) then writeln('Равнобедренный ');
if (a<>b) and (b<>c) and (a<>c) then writeln('Разносторонний ');
if (a=90) or (b=90) or (c=90) then writeln('Прямоугольный ');
if (a>90) or (b>90) or (c>90) then writeln('Тупоугольный ');
if (a<=89) and (b<=89) and (c<=89) then writeln('Остроугольный ')
end
else
writeln('Углы должны быть больше 0')
else
writeln('Сумма углов не равна 180 градусам');
end.
Новые вопросы