Составить программу «Календарь XX столетия» , которая определяет день недели любого дня XX-го столетия. По введенному значению 1, 2, 3 вычисляет
1.номер дня недели по формуле, где D- день, М-месяц, G-год:
•S=[(12-M)/10]
•K=[(G-1900-S)*365,25]+[(M+12*S-2)*30,59]+D+29
•N=K-7[K/7] (N-вычисляется от 0-воскресенье до 6-суббота, []-целая часть)
2.день недели по его номеру
3.выход
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.0, сборка 1128
begin
var D:=ReadInteger('Номер дня (1-31)');
var M:=ReadInteger('Номер месяца (1-12)');
var G:=ReadInteger('Номер года (1900-1999)');
var S:=(12-M) div 10;
var K:=Trunc(Int((G-1900-S)*365.25)+Int((M+12*S-2)*30.59)+D+29);
var N:=K mod 7;
case N of
0:Writeln('Воскресенье');
1:Writeln('Понедельник');
2:Writeln('Вторник');
3:Writeln('Среда');
4:Writeln('Четверг');
5:Writeln('Пятница');
6:Writeln('Суббота')
end
end.
begin
var D:=ReadInteger('Номер дня (1-31)');
var M:=ReadInteger('Номер месяца (1-12)');
var G:=ReadInteger('Номер года (1900-1999)');
var S:=(12-M) div 10;
var K:=Trunc(Int((G-1900-S)*365.25)+Int((M+12*S-2)*30.59)+D+29);
var N:=K mod 7;
case N of
0:Writeln('Воскресенье');
1:Writeln('Понедельник');
2:Writeln('Вторник');
3:Writeln('Среда');
4:Writeln('Четверг');
5:Writeln('Пятница');
6:Writeln('Суббота')
end
end.
Новые вопросы