Составить программу : Как найти номер первого нечётного элемента? Через массив
Ответы на вопрос
var
A: array [1..10] of Integer;
i: Integer;
IsFound: Boolean;
begin
Randomize;
Write ('Массив: ');
for i := 1 to 10 do begin
A [i] := Random (10) + 1; // заполняем массив случайными числами от 1 до 10
Write (IntToStr (A[i]) + ' '); // показываем значения массива
end;
WriteLn;
IsFound := False;
for i := 1 to 10 do begin
if A [i] mod 2 <> 0 then begin // проверка на нечетность
IsFound := True; // если найдено нечетное число устанавливаем флаг
Break; // и выходим из цикла
end;
end;
if IsFound then // если было найдено нечетное число выводим его
WriteLn ('Номер первого нечетного элемента: ' + IntToStr (i))
else // иначе сообщаем о неудаче
WriteLn ('Нечетный элемент в массиве не найден');
end;