Информатика, вопрос задал ruzengaglojty , 7 лет назад

Составить программу к задаче: Найти сумму элементов массива с четными номерами, содержащего N элементов. Элементы вводятся с клавиатуры.

умоляю помогите !!! ​


Prisonofknowledge: На каком языке то пх
ruzengaglojty: надо в паскале создать
Prisonofknowledge: Тебе просто нужно завести массив на N элементов, потом в цикле вводить с клавиатуры и считывать значения в каждую ячейку, а потом в цикле for просто кладываешь все элементы массива у которых счетчик (номер элемента) будет четный, пока счетчик не превысит количество элементов в массиве
ruzengaglojty: можешь пожалуйста это записать как в программе Паскаль
Prisonofknowledge: На паскале не прогаю сори, но концепция именно такая, это не сложно
ruzengaglojty: Я просто вообще не понимаю что там надо делать
ruzengaglojty: ладно, спасибо огромное
Prisonofknowledge: Могу только на плюсах написать)
ruzengaglojty: это как
Synt4x: так язык все же какой?

Ответы на вопрос

Ответил restIess
2

const

N = 10;

var

arr : array[1..N] of integer;

i, _sum : integer;

begin

_sum := 0;

for i := 1 to N do

   readln(arr[i]);

i := 2;

while i <= N do

   begin

   _sum := _sum + i;

   i := i + 2;

   end;

writeln(_sum);

end.


ruzengaglojty: спасибо огромное
Новые вопросы