Составить программу к следующей задаче. Задан случайным образом одномерный массив из N действительных чисел в диапазоне от -10 до 50. Подсчитать сколько в нем элементов больше (10).
Ответы на вопрос
Ответил nedro
0
Код будет работать в Pascal ABC
(в остальных программах нужно поменять функцию рандома чисел)
program p1;
var
//Пусть массив будет состоять из 50 элементов
n:array[1..50] of integer;
i, j, s:integer;
begin
//Создание массива случайный чисел от -10 до 50
for i:= 1 to 50 do
begin
n[i]:= random(-10, 50);
writeln(n[i]);
end;
//Подсчет
for j:= 1 to 50 do
begin
if n[j] > 10 then
begin
s:=s+1;
end;
end;
WriteLn('Элементов больше 10: ', s);
end.
Новые вопросы