Составить программу, используя одномерные массивы:
Найти наименьший элемент в числовом массиве М (20), который лежит в интервале [10.50]
(Pascal)
Ответы на вопрос
Ответил huston81
1
Ответ:
var
m: array[1..20] of integer;
i, min: integer;
begin
randomize;
min := 100;
WriteLn('Массив:');
for i := 1 to 20 do
begin
m[i] := random(100);
Write(m[i], ', ');
if (m[i] < min) and (m[i] >= 10) and (m[i] <= 50) then min := m[i];
end;
WriteLn;
if min <> 100 then WriteLn('Минимальный элемент массива в интервале [10..50] равен ', min)
else WriteLn('Массив не содержит элементов в интервале [10..50]');
end.
Объяснение:
Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
Математика,
2 года назад
Алгебра,
2 года назад
Геометрия,
8 лет назад