Составить программу и её блок-схему для вычисления одномерного массива:
В целочисленном массиве Х (N) найти номера и значение максимального парного и минимального нечетного элементов массива.
(Pascal)
Ответы на вопрос
Ответил huston81
1
Ответ:
var
a: array of integer;
n, i, maxpar, minn: integer;
begin
Write('Введите размер массива N: '); ReadLn(n);
SetLength(a, n);
randomize;
minn := 51;
WriteLn('Массив:');
for i := 0 to n - 1 do
begin
a[i] := random(50) + 1;
Write(a[i], ', ');
if (a[i] < minn) and (a[i] mod 2 = 1) then minn := a[i];
end;
WriteLn;
Sort(a);
for i := 0 to n - 2 do
if a[i] = a[i + 1] then maxpar := a[i];
if maxpar <> 0 then WriteLn('Максимальный парный элемент равен ', maxpar)
else WriteLn('В массиве нет парных элементов');
WriteLn('Минимальный нечетный элемент равен ', minn);
end.
Объяснение:
Новые вопросы
Английский язык,
2 года назад
Українська мова,
2 года назад
Литература,
2 года назад
Биология,
2 года назад
ОБЖ,
8 лет назад
Биология,
8 лет назад