Составить программу и блок-схему для вычисления суммы площадей всех квадратов, стороны которых изменяются в цикле от 1 до 10. В отчет включить тексты программ на Паскале, результаты работы в виде скриншотов окна программы с отображением кодов и результатов работы.
Ответы на вопрос
Ответил NaaMan
10
Ответ:
program Square_Sum;
var Sum, S, a : Integer;
begin
a := 1;
writeln('Sum is ', Sum);
while a<=10 do
begin
S := a*a;
Sum := Sum + S;
writeln('a = ', a, ', S = ', S, ', Sum is ', Sum);
a := a + 1;
end;
writeln('Total Sum is ', Sum);
end.
Блок-схема и результат работы программы:
Приложения:


Новые вопросы