Информатика, вопрос задал asphyxik , 2 года назад

Составить программу-генератор пифагоровых троек. Пифагоровой тройкой называют такие целые числа a, b и c, которые удовлетворяют условию a^{2} + b^{2} = c^{2}. Известно, что существует прямоугольный треугольник с такими длинами сторон. Найдем все пифагоровы тройки для c>=5.


Аноним: На каком языке? Я могу сделать только на Python и на C#, но на C# будет дольше
Аноним: ок

Ответы на вопрос

Ответил Аноним
0

Ответ:

def find_product(sum):

   for a in range(1, sum):

       for b in range(1, sum - a):

           c = sum - a - b

           if a**2 + b**2 == c**2:

                   print(a*b*c)

                   return a*b*c

           else:

               pass

   print('Триплет не найден!')

a = input("Введите число:  ")

find_product(int(a))

Объяснение:


Аноним: Ну, на этом наши полномочия - всё. Задай вопрос на Хабре https://qna.habr.com/
Новые вопросы