Составить программу формирования массива А из N случайных вещественных чисел, сделать возможным его редактирование. Вычислить сумму дробных частей положительных элементов массива.
morfisleep:
Еще бы было понятно что тут написано. Было бы вообще замечательно.
Ответы на вопрос
Ответил Аноним
0
{$APPTYPE CONSOLE}
Const
N = 13;
Var
A:array[1..N] of real;
i,C:integer;
Procedure ZAPOLNENIERND();
Var i,j:integer;
Begin
Randomize;
For i:= 1 to N do
A[i]:=random*21-10;
End;
Procedure BbIBOD();
Var i,j:integer;
Begin
For i:= 1 to n do
Write(A[i]:4:1,' ');
WriteLn;
End;
Procedure RE();
Begin
Write('i = ');ReadLn(i);
Write('A[',i,'] = ');ReadLn(A[i]);
End;
Procedure SF();
Var
i:integer;
S:real;
Begin
S:=0;
For i:= 1 to n do
if A[i] > 0 then S:=S+Frac(A[i]);
WriteLn('S = ',S);
End;
Begin
ZAPOLNENIERND();
BbIBOD();
Repeat
WriteLn;
WriteLn('1 - заполнить массив случайными числами');
WriteLn('2 - ввести новое значение заданного элемента');
WriteLn('3 - вычислить сумму дробных частей положительных элементов массива. ');
WriteLn('4 - вывод массива');
WriteLn('9 - выход');
ReadLn(C);
Case C of
1:
Begin
ZAPOLNENIERND;
BbIBOD;
End;
2:RE;
3:
Begin
SF();
End;
4:BbIBOD;
End
Until C = 9;
End.
Const
N = 13;
Var
A:array[1..N] of real;
i,C:integer;
Procedure ZAPOLNENIERND();
Var i,j:integer;
Begin
Randomize;
For i:= 1 to N do
A[i]:=random*21-10;
End;
Procedure BbIBOD();
Var i,j:integer;
Begin
For i:= 1 to n do
Write(A[i]:4:1,' ');
WriteLn;
End;
Procedure RE();
Begin
Write('i = ');ReadLn(i);
Write('A[',i,'] = ');ReadLn(A[i]);
End;
Procedure SF();
Var
i:integer;
S:real;
Begin
S:=0;
For i:= 1 to n do
if A[i] > 0 then S:=S+Frac(A[i]);
WriteLn('S = ',S);
End;
Begin
ZAPOLNENIERND();
BbIBOD();
Repeat
WriteLn;
WriteLn('1 - заполнить массив случайными числами');
WriteLn('2 - ввести новое значение заданного элемента');
WriteLn('3 - вычислить сумму дробных частей положительных элементов массива. ');
WriteLn('4 - вывод массива');
WriteLn('9 - выход');
ReadLn(C);
Case C of
1:
Begin
ZAPOLNENIERND;
BbIBOD;
End;
2:RE;
3:
Begin
SF();
End;
4:BbIBOD;
End
Until C = 9;
End.
Новые вопросы
Математика,
1 год назад
Английский язык,
1 год назад
Русский язык,
2 года назад
Математика,
7 лет назад
Литература,
7 лет назад