Информатика, вопрос задал Meinstory , 2 года назад

Составить программу двумерного массива состоящую из 3 столбцов и 10 строк целых чисел. Ввод осуществляется по формуле a[i,j]:=(a=1)/j+j


petyaGavrikov: (a=1)/j+j ???
Meinstory: i+j*
petyaGavrikov: a[i,j]:=(i+j)/j+j ???

Ответы на вопрос

Ответил petyaGavrikov
1
const n=10; m=3;
var 
a:array[1..n,1..m] of real;
i,j:integer;
begin
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=(i+j)/j+j;
   write(a[i,j]:6:2);
  end;
  writeln;
 end;
end.

Результат:
 3.00 3.50 4.33
 4.00 4.00 4.67
 5.00 4.50 5.00
 6.00 5.00 5.33
 7.00 5.50 5.67
 8.00 6.00 6.00
 9.00 6.50 6.33
10.00 7.00 6.67
11.00 7.50 7.00
12.00 8.00 7.33

Meinstory: Моё почтение
Новые вопросы