Информатика, вопрос задал Кекнутный , 8 лет назад

Составить программу для вывода квадратных корней из чисел от 1 до 20

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  Range(1,20).Tabulate(x->sqrt(x)).Println(NewLine)
end.

Результат
(1,1)
(2,1.4142135623731)
(3,1.73205080756888)
(4,2)
(5,2.23606797749979)
(6,2.44948974278318)
(7,2.64575131106459)
(8,2.82842712474619)
(9,3)
(10,3.16227766016838)
(11,3.3166247903554)
(12,3.46410161513775)
(13,3.60555127546399)
(14,3.74165738677394)
(15,3.87298334620742)
(16,4)
(17,4.12310562561766)
(18,4.24264068711928)
(19,4.35889894354067)
(20,4.47213595499958)

Традиционное решение
var
  i:integer;
begin
  for i:=1 to 20 do Writeln(i:2,sqrt(i):16:12)
end.

Результат
 1  1.000000000000
 2  1.414213562373
 3  1.732050807569
 4  2.000000000000
 5  2.236067977500
 6  2.449489742783
 7  2.645751311065
 8  2.828427124746
 9  3.000000000000
10  3.162277660168
11  3.316624790355
12  3.464101615138
13  3.605551275464
14  3.741657386774
15  3.872983346207
16  4.000000000000
17  4.123105625618
18  4.242640687119
19  4.358898943541
20  4.472135955000


Новые вопросы