Информатика, вопрос задал ElinaMiller88 , 8 лет назад

Составить программу для вычисления среднеарифметического N произвольных чисел.

Обозначения:
S-сумма всех чисел;
SR-среднеарифметическое N чисел;
A-значение I-го числа;
N-количество чисел.

Ответы на вопрос

Ответил dddd66
0
PROGRAM PR17;
  VAR
   I,N:INTEGER;
    S,SR,A:REAL:
  BEGIN
    WRITE(‘ Введите N’);
    READLN(N);
     S:=0;
       FOR I:=1 TO N DO
        BEGIN
        WRITE(‘ Введите ‘,I,’ число’);
        READLN(A);
       S:=S+A:
        END;
              SR:=S/N;
                                                                                      43 WRITELN(‘Ответ: SR = ’,SR:8:3);
END.
Новые вопросы