составить программу для вычисления квадратного уравнения пдпжпж Паскальь
Ответы на вопрос
Ответил Ment237
0
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
var
a, b, c: integer;
D, x1, x2: real;
begin
writeln('Введите коэффициенты квадратного уравнения: ');
readln(a, b, c);
D:=sqr(b) - 4*a*c;
if D < 0 then writeln('Корней нет!')
else if D = 0 then
begin
x1:=-c / b;
writeln('Корень: ', x1:0:2);
end
else
begin
x1:=(-b + sqrt(D)) / 2*a;
x2:=(-b - sqrt(D)) / 2*a;
writeln('x1 = ', x1:0:2);
writeln('x2 = ', x2:0:2);
end;
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Литература,
7 лет назад
Математика,
7 лет назад
Алгебра,
9 лет назад