Информатика, вопрос задал Doge51 , 7 лет назад

Составить программу для вычесления:
2/4 * 3/5 * 4/6 *.....
Срочно

Ответы на вопрос

Ответил vunderkid
0

var

i: integer;

mul,a,b: real;

begin

sum:=1; a:=2; b:=4;

for i:=1 to 10000 do

begin

 mul:=mul*a/b;

a:=a+1;

b:=b+1;

end;

writeln('результат', mul);

end.

Ответил Browze
0

Дабы не делать многочисленные операции в пустую, от пользователя требуется ввод числа А, до которого будет идти итерация.(формат числа: A/B, ввод - А)

#include <iostream>

#include <iomanip>

int main()

{

int N;

float sum(1);

std::cout << "Введите число A, до которого будут идти итерации(A/B): ";

std::cin >> N;

for(float i = 2; i < N; i++)

 sum *= i/(i+2);

std::cout << "Результат = " << std::setprecision(5) << sum << std::endl;

}

Приложения:
Новые вопросы