Информатика, вопрос задал Kostyanus , 9 лет назад

Составить программу для ввода в ЭВМ произвольной вещественной матрицы размером M*N и вывода первого не равного заданному S элемента каждой строки.

Сама программа у меня есть,она работает,но ее нужно написать БЕЗ ''break''!

Приложения:

Ответы на вопрос

Ответил Gleb1Kosyrev
0
var ma:array of array of real;
i,j,s,m,n,k:integer;
begin;
randomize;
writeln('Введите S:');
readln(s);
writeln('Введите размерность матрицы:');
readln(n);
readln(m);
setlength(ma,n+1);
for i:=1 to n do
setlength(ma[i],m+1);
writeln('Введите матрицу:');
for i:=1 to n do
  for j:=1 to m do
   read(ma[i,j]);
writeln('Matrix:');
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to m do
     write(ma[i,j]:4);
 end;
writeln;
writeln('Results:');
for i:=1 to n do
begin;
 for j:=1 to m do
  if (ma[i,j]<>s) and (k=0) then
    begin;
    k:=1;
    writeln(ma[i,j]);
    end;
 k:=0;
end;
end.
Ответил Kostyanus
0
Спасибо,это то что надо,но нужно что бы было не рандомно,а самому вводить матрицу
Новые вопросы